The Un-Official Proxomitron Forum
Proxomitron reduces RWIN to 32768 - Printable Version

+- The Un-Official Proxomitron Forum (http://www.prxbx.com/forums)
+-- Forum: Forum Related (/forumdisplay.php?fid=37)
+--- Forum: Proxomitron Program (/forumdisplay.php?fid=4)
+--- Thread: Proxomitron reduces RWIN to 32768 (/showthread.php?tid=641)

Pages: 1 2 3 4 5 6 7 8 9 10 11


Proxomitron reduces RWIN to 32768 - Tony Tough - Oct. 19, 2005 06:12 AM

I'm using Proxomitron with IE 6.0.
The problem is that it sets my RWIN to 32768 (according to the speedguide analyzer
http://forums.speedguide.net:8117 )
regardless what is set up in the registry and therefore downloads from distant servers are very slow.

As soon as I deactivate the local Proxy (localhost:8080) in the IE options I have full speed and the speedguide analyzer displays the correct RWIN of 253440, but then of course the Proxomitron doesn't work because it needs that local proxy.

I tested an other web filter in the meantime called BFilter (also with localhost:8080 as proxy setting) and there
http://forums.speedguide.net:8117
shows the correct RWIN from windows registry (253440) and I have full download speed.

And of course only http:// from servers with higher latency is affected not ftp or other protocols
For example:
with activated proxomitron on localhost:8080 I get about 120 KB/s from a http server with about 215 ms latency with one connection downloading a very large rar or zip file.
Without the local proxy 8080 I get 550 KB/s with one connection.
With BFilter (another program like proxomitron that works similar and also via localhost:8080) I also get 550 KB/s.

I also tried proxomitron with different filters, with no filters or bypass : all the same effect.
Also no difference with firefox or opera web browser.

So I think that the problem is inside the proxomitron.exe, which doesn't work 100% with my system configuration and sends that low RWIN in the tcp/ip headers to other servers.


Anyone can help me?
Thanks in advance


- Kye-U - Oct. 19, 2005 09:23 PM

I experience the same thing. (Proxomitron 4.5j). I think it's related to the way Scott programmed Proxomitron.

I will post this to Prox-List, and I'll post any updates here Smile! I'm posting this there because there are a lot of experienced Proxomitron users there who know the background of the program.

BTW, for those who want to test their RWin:

http://www.speedguide.net/analyzer.php


- elshaddai - Oct. 20, 2005 12:13 AM

I never had any problems with Proxo modifing my RWIN. The speedguide analyzer shows my correct RWIN. I use a Dr.TCP ( a registry GUI) to fiddle around with MTU and RWIN values.

http://www.dslreports.com/drtcp

or

TCP optimizer

http://www.speedguide.net/downloads.php


- Kye-U - Oct. 20, 2005 05:00 AM

Quote:Bet you both have SP2.
I have read that SP1 was OK.
Win98 is OK.
So Microsoft did it. ;-)

--
JJoe

Perhaps when a proxy server is used in SP2, the RWIN is limited?


- Guest - Oct. 20, 2005 06:13 AM

Kye-U Wrote:Perhaps when a proxy server is used in SP2, the RWIN is limited?

Yes I'm using Win XP SP2.
But it's only when I use proxomitron.
BFilter and also Proximodo are OK and submit the correct RWIN.


- Tony Tough - Oct. 20, 2005 06:15 AM

Any idea, how I can resolve this issue.
(Uninstalling SP2 is no option)


- Peakaboo - Oct. 20, 2005 05:27 PM

Kye-U,

I'm watching this unfold. Appreciate all you have done so far in posting and following-up @ proxy-list yahoo for Tony and possibly for others who may not even realize this problem exists.

Sounds like the issue is OS specific and to drill it down it appears to be a SP2 issue.

If it is an unfixable programming issue, I wonder if a header filter can be written for proxo to intercept the limiting bad 32768 rwin and replace it with the correct registry rwin before it is sent out...

this assumes the limiting RWIN header data being sent to the remote server is the issue

you are the filter maestro so, maybe you are already on this line of thinking...

something like match on rwin 32768 out and if so change to value @

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP

and pick up defaultRcvWindow value

or wherever it resides in WinXP

if above is not possible maybe match and go with a user defined rwin

just wanted to throw out an idea as a possible workaround to see if it is even possible assuming the issue at hand is not fixable due to a programming issue with SP2 or Proxo.exe...

p.s. don't laugh but I have just exhausted my limited input on this not knowing how RWIN works with high latency remote servers... I'm thinking the server uses the rwin data to know when to expect a response from your local pc so it can pour more data into the pipe... oh well Wink


- Kye-U - Oct. 20, 2005 07:52 PM

I don't think Proxomitron can modify the RWin value, as it's specified in the TCP Packet's connection request.

I am quite curious in what's the reason for this phenomenon. Smile!


- Oddysey - Oct. 21, 2005 07:50 AM

Kye-U;

I'd have to question JJoe's answer. How is it that last piece of the pie in the communications chain, Proxo, can write a packet that basically limits the RWIN value, and do so only if it's being run under a certain OS? That just boggles my mind. Eek That would require that Proxo be OS dependent, something that I thought Scott assiduously avoided (well, all versions of Windows anyway).

The only way to tell if JJoe's source is correct is to test on W2K, and maybe Win98 too. If those come up clean (RWIN is unaltered), then I'd be highly curious to know if this has been happening for some time, as in, with earlier versions of Proxo. If RWIN is being limited under any of these other scenarios, then Scott probably did this on purpose, for whatever reason that seemed good to him at the time. If the problem only shows up under XP/SP2 and Proxo 4.5j, then there very likely is an OS dependency of which I was unaware. Not even sure that such a thing could be fixed at all, let alone with just a filter. Sad


Oddsey


- Tony Tough - Oct. 21, 2005 08:19 AM

The problem also shows up with Proxo 4.3.
BFilter and proximodo submit the correct RWIN.

I wonder, why I seem to be the first one who noticed this problem, as high speed internet becomes more and more common.

Maybe a lot of people use a router, which corrects the RWIN value, but I use a direct connection to the internet with no router.

If there is no fix possible, proxo can not be recommended for broadband users anymore because of that 32768 limitation.


Same problem under windows98SE - mambo - Oct. 21, 2005 08:27 AM

Hi everyone!

Just to inform RWIN is limited to 32768 under Windows98SE as well. It seems the problem resides on Proxomitron.

mambo


- Ralph - Oct. 21, 2005 12:11 PM

Mambo , not on my Win 98SE system . I am on cable and my Rwin is 256,960 .


- Tony Tough - Oct. 21, 2005 12:24 PM

Ralph Wrote:Mambo , not on my Win 98SE system . I am on cable and my Rwin is 256,960 .

Maybe that's because the cable modem works as a router and the RWIN ist set by your modem?

I'm on DSL and directly connected via PPPOE.


- Peakaboo - Oct. 21, 2005 12:39 PM

Tony Tough Wrote:The problem also shows up with Proxo 4.3.
BFilter and proximodo submit the correct RWIN.

Maybe a lot of people use a router, which corrects the RWIN value, but I use a direct connection to the internet with no router.

If there is no fix possible, proxo can not be recommended for broadband users anymore because of that 32768 limitation.

I use 4.3 Proxo on win95 behind a router with a software firewall and am not experiencing this problem. I'm connected via Cable. Dwnld speed is approx 94.5% of advertised & TCP/IP analyzer shows my correct RWIN.

How many of those reporting this problem are using winXP sp2?

I agree with your last statement to a point, maybe a warning that this may be an issue to test for is more appropriate. The simple test is to go here:

http://forums.speedguide.net:8117/

either you have the problem or not.


- mambo - Oct. 21, 2005 12:46 PM

Hi!

As Tony Tough, i'm on DSL and directly connected via PPPOE, too. By the way, when i choose a RWIN below 32768 and use Proxomitron but bypass filters, SpeedGuide test shows the correct RWIN.

mambo