The Un-Official Proxomitron Forum
Found a precompiled zlib.dll version 1.27 - Printable Version

+- The Un-Official Proxomitron Forum (https://www.prxbx.com/forums)
+-- Forum: Forum Related (/forumdisplay.php?fid=37)
+--- Forum: Proxomitron Program (/forumdisplay.php?fid=4)
+--- Thread: Found a precompiled zlib.dll version 1.27 (/showthread.php?tid=2065)



Found a precompiled zlib.dll version 1.27 - Belarathon - Dec. 04, 2012 04:57 PM

zlib.dll version 1.27 download


Alternately, you can go to Gregory Morse's VB page and find the download, which is the last item on the web page.

Extract the zip, then find the "dll32" folder. Find the file "zlibwapi.dll" and rename it to "zlib.dll."

Close Proxomitron, then in the root directory of Proxo, rename your existing zlib.dll (in my case, I simply overwrote version 1.25, and have had no issues after many days of use).
Place the new .dll in the Proxomitron root directory, then restart. It's all good!


RE: Found a precompiled zlib.dll version 1.27 - metaprxbx - Feb. 13, 2014 06:56 PM

Question...
CAN I use the dllx64 version of zlibwapi.dll (renaming to zlib.dll of course)? I'm on Win7x64 and x64 cpu... or must I use the dll32 version with Proxomitron?

Next question, at - http://www.zlib.net/ - one can find a link labled: "zlib compiled DLL, version 1.2.8, zipfile format"... in which you get a file called zlib1.dll (no 32 or x64 directories here). Is such a file compatible/preferable to use with Proxomitron (if renamed)?


RE: Found a precompiled zlib.dll version 1.27 - JJoe - Feb. 13, 2014 08:32 PM

(Feb. 13, 2014 06:56 PM)metaprxbx Wrote:  Question...
CAN I use the dllx64 version of zlibwapi.dll (renaming to zlib.dll of course)? I'm on Win7x64 and x64 cpu... or must I use the dll32 version with Proxomitron?

I think you must use the dll32 version but I have never tried the dllx64.

(Feb. 13, 2014 06:56 PM)metaprxbx Wrote:  Next question, at - http://www.zlib.net/ - one can find a link labled: "zlib compiled DLL, version 1.2.8, zipfile format"... in which you get a file called zlib1.dll (no 32 or x64 directories here). Is such a file compatible/preferable to use with Proxomitron (if renamed)?

I don't think it is compatable but I haven't tried it
The Proxomitron needs a particular build of zlib.dll. Afaik, only Gilles Vollant and perhaps Gregory Morse provide it.

HTH


RE: Found a precompiled zlib.dll version 1.27 - Belarathon - Feb. 14, 2014 02:11 AM

(Feb. 13, 2014 06:56 PM)metaprxbx Wrote:  Question...
CAN I use the dllx64 version of zlibwapi.dll (renaming to zlib.dll of course)? I'm on Win7x64 and x64 cpu... or must I use the dll32 version with Proxomitron?


I've tried it - it will not work.

Incidentally, a new precompiled zlib.dll - version 1.2.8 can be downloaded here: zlibnet - c# zlib wrapper library

rename zlib32.dll to zlib.dll and replace existing file in your Proxo program directory.

Personally tested and used by me for a good while - works fine.


RE: Found a precompiled zlib.dll version 1.27 - whenever - Dec. 23, 2018 03:54 AM

(Feb. 14, 2014 02:11 AM)Belarathon Wrote:  Incidentally, a new precompiled zlib.dll - version 1.2.8 can be downloaded here: zlibnet - c# zlib wrapper library

That project is migrated to https://github.com/gdalsnes/zlibnet and the latest version 1.2.8.1 seems working.