Post Reply 
How to change Proxo Connection Error message
Apr. 25, 2008, 12:44 PM
Post: #1
How to change Proxo Connection Error message
Greetings, Proxomitron Fans Everywhere!

I've used Proxomitron for a long, long time -- it's still part of my 'computer staples.'

OS: WinXP SP2
Browser: Opera 1.26
Proxomitron version: 4.5j

Question: Is there a way to replace the Proxo connection error message that appears in blocked ad spaces with a clear image or other blank image? See example below.


.gif  ProxoConnectErrorMsg.gif (Size: 18.53 KB / Downloads: 663)

I am able to do that using eDexter to replace blocked urls (via host file) but I would like to do this with Proxomitron's connection error message. I have no idea where to find this in the Proxomitron folder.

Since I am capable of doing some basic things with html and such, I would appreciate some guidance.

Thanks!

janusz
Add Thank You Quote this message in a reply
Apr. 25, 2008, 01:59 PM
Post: #2
RE: How to change Proxo Connection Error message
Have a look at the Proxomitron\html directory.
Add Thank You Quote this message in a reply
Apr. 25, 2008, 03:28 PM
Post: #3
RE: How to change Proxo Connection Error message
Thanks for replying. I appreciate it. Yes, it was my first stop. I did not find anything obvious. Perhaps you could identify it for me?

Thanks!
j
Add Thank You Quote this message in a reply
Apr. 25, 2008, 04:49 PM
Post: #4
RE: How to change Proxo Connection Error message
You can change the image here:

**Proxomitron Folder**\html\ProxyLogo.jpg

The HTML is hard-coded into Proxomitron, so unless you want to delve into hex editing, you can also modify the appearance of the page by editing its CSS file:

**Proxomitron Folder**\html\Errors.css

I guess what you'd want to do is aim to make everything appear white: replace ProxyLogo.jpg with a white jpg, then set the body bg, table borders, table background to all white Smile! (via the css file)

Welcome!
Visit this user's website
Add Thank You Quote this message in a reply
Apr. 25, 2008, 06:24 PM
Post: #5
RE: How to change Proxo Connection Error message
Thanks!!!

Well, I was able to make the changes. White images, text color white, yet the error message is still visible:

Error connecting to site

The Proxomitron couldn't connect to...
mediamgr.ugo.com:80/html.ng/size=300x250&affiliate=allmovieportal&channel=filmtv&subchannel=alsoplaying&Net
The site may be busy or the web server may be down.

Is there a way to mask the message using a header entry of some kind?

j
Quote this message in a reply
Apr. 25, 2008, 09:35 PM
Post: #6
RE: How to change Proxo Connection Error message
Try this (backup your Errors.css file first) Smile!:

Code:
/*
   Proxomitron Error Message Style Sheet
*/

body
{
  background-color: #FFFFFF;
}

table table p
{
  display: none
}

td img
{
  display: none
}

.err1
{
  display:none
}

.err2
{
  display:none
}
Visit this user's website
Add Thank You Quote this message in a reply
Apr. 26, 2008, 12:35 PM
Post: #7
RE: How to change Proxo Connection Error message
Thanks, Kye-U!! I appreciate it very much.

Here is what I get:


.gif  ErrorMsg.gif (Size: 3.17 KB / Downloads: 629)

Summary: I use host file to block URLs. I only get the connection error message when 1) the host file blocks a URL and 2) when I have BYPASS FILTERS active (no filtering) in Proxo.

When I have Proxo working as normal (full filtering), I do not get a connection message, just a blank or white space. So it seems that a Proxo filter seems to be doing the job and blocking the error message!!

Why not leave Proxo filtering "on"? On some sites that I may only visit one or two times I may not want to filter for variety of reasons (i.e., flash, javascript, etc.). I thought that if Proxo could remove the error message then I would have little reason to use eDexter. (eDexter does not work well with Opera, unlike other browsers, in that a web page does not resize to eDexters "invisible" images and the error message often comes through anyway.) eDexter was disabled during the above "tests."

Any thoughts or suggestions?

j
Add Thank You Quote this message in a reply
Post Reply 


Forum Jump: