Post Reply 
CloseLocal = TRUE
Oct. 21, 2009, 06:12 PM
Post: #1
CloseLocal = TRUE
What does this do? Seems to being stopping some sites from loading without refreshing them, only some sites are bad. CloseLocal = false fixes the problems.
Thanks Charlie
Add Thank You Quote this message in a reply
Oct. 21, 2009, 11:12 PM
Post: #2
RE: CloseLocal = TRUE
(Oct. 21, 2009 06:12 PM)turtle Wrote:  What does this do?

That's related to the "Local connections persist for:" option in the "HTTP" tab of the settings dialog.
"CloseLocal = TRUE" is "Local connections persist for:" disabled.

http://www.proxomitron.info/45/docs/Changes.txt Wrote:* Added persistent connection support to local connections as well
as remote. For best results make sure your browser is set to use
HTTP/1.1 through the proxy and has pipelining enabled (if it's an
option). Also I recommend about 6-8 simultaneous connections. With
this, Proxomitron now supports nearly all of HTTP/1.1's optional
features.

For this to work Proxomitron must make heavy use of "chunked"
encoding since we can't know the size of a filtered item ahead of
time. This shouldn't be a problem, but it's possible some browsers
may not expect so many items to be "chunked" - especially images.
In testing Mozilla seems to have some random problems with chunked
encoding if pipelining is enabled, but the flaw doesn't seem to be
in Proxomitron's handling of things (Pipelining support in Mozilla
is new and may still be a bit buggy). Opera, which also heavily
pipelines, seem ok.

HTTP/1.0 persistence is also supported. However, since Proxomitron
frequently makes changes to an item's content-length and HTTP/1.0
does not allow for chunked encoding, fewer requests may be able
to persist if your filtering.

Local persistence can be turned off if necessary and it's keep-alive
time adjusted under the HTTP tab of the Config dialog. By default
local connections are killed after 10 seconds of inactivity. That
should be fine in most cases since new local connections are fairly
fast to create, but you may wish to increase this - especially if
you're using Proxomitron remotely over a LAN.

(Oct. 21, 2009 06:12 PM)turtle Wrote:  Seems to being stopping some sites from loading without refreshing them, only some sites are bad. CloseLocal = false fixes the problems.

Have you enabled HTTP/1.1 through the proxy?
It's a browser setting.

HTH


Attached File(s)
.gif  LCP.gif (Size: 44.24 KB / Downloads: 627)
Add Thank You Quote this message in a reply
Oct. 22, 2009, 01:42 AM
Post: #3
RE: CloseLocal = TRUE
(Oct. 21, 2009 11:12 PM)JJoe Wrote:  
(Oct. 21, 2009 06:12 PM)turtle Wrote:  What does this do?

That's related to the "Local connections persist for:" option in the "HTTP" tab of the settings dialog.
"CloseLocal = TRUE" is "Local connections persist for:" disabled.

http://www.proxomitron.info/45/docs/Changes.txt Wrote:* Added persistent connection support to local connections as well
as remote. For best results make sure your browser is set to use
HTTP/1.1 through the proxy and has pipelining enabled (if it's an
option). Also I recommend about 6-8 simultaneous connections. With
this, Proxomitron now supports nearly all of HTTP/1.1's optional
features.

For this to work Proxomitron must make heavy use of "chunked"
encoding since we can't know the size of a filtered item ahead of
time. This shouldn't be a problem, but it's possible some browsers
may not expect so many items to be "chunked" - especially images.
In testing Mozilla seems to have some random problems with chunked
encoding if pipelining is enabled, but the flaw doesn't seem to be
in Proxomitron's handling of things (Pipelining support in Mozilla
is new and may still be a bit buggy). Opera, which also heavily
pipelines, seem ok.

HTTP/1.0 persistence is also supported. However, since Proxomitron
frequently makes changes to an item's content-length and HTTP/1.0
does not allow for chunked encoding, fewer requests may be able
to persist if your filtering.

Local persistence can be turned off if necessary and it's keep-alive
time adjusted under the HTTP tab of the Config dialog. By default
local connections are killed after 10 seconds of inactivity. That
should be fine in most cases since new local connections are fairly
fast to create, but you may wish to increase this - especially if
you're using Proxomitron remotely over a LAN.

(Oct. 21, 2009 06:12 PM)turtle Wrote:  Seems to being stopping some sites from loading without refreshing them, only some sites are bad. CloseLocal = false fixes the problems.

Have you enabled HTTP/1.1 through the proxy?
It's a browser setting.

HTH

Looks like it got unchecked in the June 6 update, reset it and put time at 40sec--that fixed sites with problem, and yes i had HTTP/1.1 w/proxy set. Thanks Charlie
Add Thank You Quote this message in a reply
Oct. 22, 2009, 02:57 PM (This post was last modified: Oct. 22, 2009 02:57 PM by defconnect.)
Post: #4
Question RE: CloseLocal = TRUE
What about the long reported problem with Proxo's persistent connections option in this respect? (To bad the relevant CastleCops reference - http://www.castlecops.com/p6911-proxo.html - is not available anymore "unchecking the local connections persist item"), but here are two other references:
http://operawiki.info/Opera7Performance
http://www.dslreports.com/forum/r20767996-
Add Thank You Quote this message in a reply
Oct. 22, 2009, 09:10 PM
Post: #5
RE: CloseLocal = TRUE
(Oct. 22, 2009 02:57 PM)defconnect Wrote:  What about the long reported problem with Proxo's persistent connections option in this respect?

I thought the answer was something like

nontroppo Wrote:I agree with HPGuru that this is a bug, but I edge towards TeggHead's appraisal that persistence is nevertheless probably handled correctly by the majority of servers, and thus this bug has little impact in the real world. But hard facts are still needed one way or the other...

http://www.gecco.dk/oldforum/index.php?topic=1695.0

Some local apps, FreeCap for one, didn't play nice with the local connections persist item checked. The browser would not always use all the connections allowed. 24 images with 12 connections might end with 1 connection getting the last 12 images, iirc.
I have also disabled it to send the keep-alive header, iirc.
Otherwise, I enable it.

A 'bug' only because I may want the header sent, imo.

fwiw, iirc
Add Thank You Quote this message in a reply
Oct. 23, 2009, 08:08 PM
Post: #6
RE: CloseLocal = TRUE
Thanks for the additional info JJoe!
Add Thank You Quote this message in a reply
Post Reply 


Forum Jump: