Post Reply 
zlib.dll version 1.2.5
Dec. 29, 2010, 04:52 PM (This post was last modified: Apr. 28, 2011 02:23 AM by JJoe.)
Post: #1
zlib.dll version 1.2.5
Attached zip contains a zlib.dll that was built by Gilles Vollant from the current zlib 1.2.5 sources. The dll was originally named zlibwapi.dll. It can replace the zlib.dll built by Gilles Vollant from the zlib 1.1.x sources that is currently used by the Proxomitron.

More information at:
http://www.winimage.com/zLibDll/index.html
http://www.zlib.net/

Report problems

Have fun

Edit: Not for Windows98. Last advertised update for Windows98 was version 1.2.3.


Attached File(s)
.zip  zlibwapi125.zip (Size: 75.78 KB / Downloads: 801)
Add Thank You Quote this message in a reply
Dec. 29, 2010, 10:21 PM
Post: #2
RE: zlib.dll version 1.2.5
What difference between the new and old?
Add Thank You Quote this message in a reply
Dec. 30, 2010, 08:13 AM
Post: #3
RE: zlib.dll version 1.2.5
The link JJoe offered has a change log: http://www.zlib.net/ChangeLog.txt
Add Thank You Quote this message in a reply
Dec. 30, 2010, 08:18 AM
Post: #4
RE: zlib.dll version 1.2.5
my bad, i mean what in it for proxomitron users.
Add Thank You Quote this message in a reply
Dec. 30, 2010, 08:58 AM
Post: #5
RE: zlib.dll version 1.2.5
Bugfixes, memory leaks, improved safety, etc.; full details in the changelog whenever referenced above.
All these enable Proxo to improve its performance (de)compressing pages.
Add Thank You Quote this message in a reply
Feb. 13, 2014, 06:46 PM
Post: #6
RE: zlib.dll version 1.2.5
Question...
I downloaded the zip/folder "zlib125dll.zip" from - http://www.winimage.com/zLibDll/index.html - which contains several folders. Long story short, should I use the dll32 or dllx64 version of zlibwapi.dll (renaming to zlib.dll of course)? I'm on Win7x64 and x64 cpu, but Proxomitron is 32-bit based... so I didn't even know if both would work, or one would fail?

One other question... I'm not supposed to build/compile anything from that .zip am I? Or should I copy any of those .lib files to the Proxomitron install directory as well?

Thanks for your help.
Add Thank You Quote this message in a reply
Feb. 13, 2014, 08:19 PM
Post: #7
RE: zlib.dll version 1.2.5
Welcome,

You only need zlibwapi.dll from the dll32 folder.
No other files are needed.
No need to build, compile, etc.

HTH
Add Thank You Quote this message in a reply
Post Reply 


Forum Jump: