Author Topic: 4.3 Crashing and Hanging  (Read 1297 times)

pooms

  • Jr. Member
  • **
  • Posts: 75
    • ICQ Messenger -
    • AOL Instant Messenger -
    • Yahoo Instant Messenger -
    • View Profile
    • Email
4.3 Crashing and Hanging
« on: June 11, 2002, 03:36:38 PM »
I started using 4.3 last night and have run into a couple of
crashes and one case where it hung and I had to kill it
through the Task Manager.

The first time it died, I wasn't paying attention, so I'm not sure
what was the cause. The second time, though, I figured out the what
happened and can repeat it. If you scroll all the way to the bottom
of either the Web Page or Header filters lists, there is a strip
of grey below the very last entry. I was trying to unselect the
last filter entry and clicked a bit too low in the dark grey area
below the checkbox. That killed Proxomitron.

I managed to hang 4.3 twice in the same manner, so this may also
be repeatable. I was switching between configuration files and
had selected File/Load Config File and clicked to open the new Config
file I wanted to load. I hadn't noticed, but there was one active
connection, and I got the warning dialogue with the Retry, Kill
Connections options. It didn't seem like there was any good reason
for there to be an active connection, so I selected the kill
connections option. At that point it completely froze. It wasn't
taking up any CPU time, but there was nothing I could do other
than kill it through the Task Manager.

Other than these problems (which can easily be avoided) I haven't
run into anything else.

 
 

sidki3003

  • Sr. Member
  • ****
  • Posts: 476
    • ICQ Messenger -
    • AOL Instant Messenger -
    • Yahoo Instant Messenger -
    • View Profile
    • http://
    • Email
4.3 Crashing and Hanging
« Reply #1 on: June 11, 2002, 04:31:16 PM »
quote:

I was trying to unselect the last filter entry and clicked a bit too low in the dark grey area below the checkbox. That killed Proxomitron.



Same here. I can only see this strip in the header list, because i haven't that many filters there.

quote:

It didn't seem like there was any good reason for there to be an active connection, so I selected the kill connections option. At that point it completely froze.



I saw this with earlier versions too (incl. 4.2). But like you i'm not too much concerned about it.


 
 

hpguru

  • Sr. Member
  • ****
  • Posts: 257
    • ICQ Messenger -
    • AOL Instant Messenger -
    • Yahoo Instant Messenger -
    • View Profile
    • http://lightning.prohosting.com/~hpguru/
    • Email
4.3 Crashing and Hanging
« Reply #2 on: June 11, 2002, 05:40:14 PM »
Doesn't happen here but that's not to say it wouldn't. I just don't see the strip you mention.

Facing each other,
a thousand miles apart.

Edited by - hpguru on 11 Jun 2002  20:31:56
Facing each other,
a thousand miles apart.

Bes

  • Newbie
  • *
  • Posts: 29
    • ICQ Messenger -
    • AOL Instant Messenger -
    • Yahoo Instant Messenger -
    • View Profile
    • Email
4.3 Crashing and Hanging
« Reply #3 on: June 11, 2002, 06:35:09 PM »
Hmmm, that one with clicking the grey strip below does'NT hang Proxo with me (The Allmighty King of BSOD's btw )

The problem with the active connections with reloading a config file does (still) kill Proxo.


Edited by - Bes on 11 Jun 2002  20:10:12
 

hpguru

  • Sr. Member
  • ****
  • Posts: 257
    • ICQ Messenger -
    • AOL Instant Messenger -
    • Yahoo Instant Messenger -
    • View Profile
    • http://lightning.prohosting.com/~hpguru/
    • Email
4.3 Crashing and Hanging
« Reply #4 on: June 11, 2002, 07:35:11 PM »
quote:

The problem with the active connections with reloading a config file does (still) kill Proxo.



That only happens here if the log window is opened at the time. I haven't actually observed this in v4.3 yet.

Facing each other,
a thousand miles apart.
Facing each other,
a thousand miles apart.

Scott Lemmon

  • Full Member
  • ***
  • Posts: 103
    • ICQ Messenger -
    • AOL Instant Messenger -
    • Yahoo Instant Messenger -
    • View Profile
    • http://proxomitron.cjb.net/
    • Email
4.3 Crashing and Hanging
« Reply #5 on: June 11, 2002, 09:54:16 PM »
Unfortunately clicking in the gray area has no ill effects whatsoever for me.  What OS and video drivers are you using? Also, you shouldn't even see a gray area unless there are not enough filters to completely fill the window (scrolling to the bottom shouldn't do it).  This will happen if you use the "find" to limit the number of filters shown, but as I said no crash for me so nothing I can debug.

-Scott-



 
 

sidki3003

  • Sr. Member
  • ****
  • Posts: 476
    • ICQ Messenger -
    • AOL Instant Messenger -
    • Yahoo Instant Messenger -
    • View Profile
    • http://
    • Email
4.3 Crashing and Hanging
« Reply #6 on: June 11, 2002, 10:00:43 PM »
I have XP here with the original/native Nvidia TNT2 drivers.
But as mentioned above, it's easy to avoid the bug

 
 

pooms

  • Jr. Member
  • **
  • Posts: 75
    • ICQ Messenger -
    • AOL Instant Messenger -
    • Yahoo Instant Messenger -
    • View Profile
    • Email
4.3 Crashing and Hanging
« Reply #7 on: June 11, 2002, 10:38:17 PM »
I'm running Windows 2000 Server SP 2 on a Thinkpad A22M laptop with
SXGA+(1400x1050) display (ATI Rage Mobility 128). Video driver is
the one provided by IBM, Version M6.31.77-T01.

The grey area shows at the bottom of both filter windows when I
scroll down(I loaded Jor's Config, so there are quite a few entries).
They only show up immediately after I start Proxomitron. If I so much as touch
the edges of the filter window with the cursor as though I was going
to resize it, (without even dragging the window edge) the bottom of
the window snaps up and eliminates that grey area.

I think this is all triggered by the fact that I downloaded and tried Jor's
Filters. That Config file has [WinSizes] entries in it, and it looks like
when Proxomitron tries to conform to those values on my display it
ends up with those grey areas. If I delete the [WinSizes] entries I
no longer see any grey area.

I guess this is a pretty obscure error! Maybe not worth fixing.

 
 

Jor

  • Sr. Member
  • ****
  • Posts: 421
    • ICQ Messenger - 10401286
    • AOL Instant Messenger - jor otf
    • Yahoo Instant Messenger - jor_otf
    • View Profile
    • http://members.outpost10f.com/~jor/
    • Email
4.3 Crashing and Hanging
« Reply #8 on: June 11, 2002, 11:24:10 PM »
I think you are right about the Winsizes, I will keep them out of uploaded config sets

I use pretty strange settings at times.