Author Topic: Log Window shows nothing at all  (Read 1946 times)

Gordon Edwards

  • Newbie
  • *
  • Posts: 8
    • ICQ Messenger -
    • AOL Instant Messenger -
    • Yahoo Instant Messenger -
    • View Profile
    • Email
Log Window shows nothing at all
« on: June 13, 2002, 04:03:10 PM »
I've installed Proxo strictly according to the instructions -- I think.  I did read them carefully, twice.

I have opened the Log Window to suss what's happening, but all I see is a patch of black.

It's running on a P2 166MMX under W98 1st ed with IE5.01, Opera 6.01 without Java, 64MB and sufficient HDD space.  Windows lives in c:SOLE.  I am using the "default.cfg" -- I think -- with the following options:

* Un-prefix URLs
* Kill All Backgrounds (even Tables)
* Blink Buster (please don't ask me why, I haven't seen a Blink tag for years!)
* OnLoad unloader
* Kill pop-up windows (Multi enabled)
* Restore pop-ups after page loads
* Link de-obfuscator
* Anti-Auto-Refresher (Multi enabled) (to deal with AltaVista)
* Wordwrap all Form text-boxes (please...)
* GeoCities branding killer
* Stop browser window resizing (Multi enabled)
* Stop status-bar scrollers (Multi enabled)
* Stop JavaScript timers
* Stop JavaScript redirects
* Kill nosey JavaScripts
* Make JS and Meta cookies session only
* Hide browser's referrer from JS
* Hide browser's version from JS
* Kill window.external methods
* Frame jumper-outer (Multi enabled)
* Kill anti-cache meta tags

While running -- as I write this now -- Proxo continuously tells me "Active connections: 00", repeated on the Log window.  Proxy is _definitely_ set to localhost: 8080.

I am using the hosts file, with entries supplied by <http://www.smartin-designs.com/> to delete ads.

What incantation must I recite?

Gordon.
 

Jor

  • Sr. Member
  • ****
  • Posts: 421
    • ICQ Messenger - 10401286
    • AOL Instant Messenger - jor otf
    • Yahoo Instant Messenger - jor_otf
    • View Profile
    • http://members.outpost10f.com/~jor/
    • Email
Log Window shows nothing at all
« Reply #1 on: June 13, 2002, 04:18:38 PM »
Hard to say... you are absolutely sure your browser is using a proxy? Also check if you are not bypassing the proxy on local addresses, or 127.0.0.1

A further thing to check is what port Proxomitron is set to: click on config, then HTTP. Default is 8080.

Also check if you are not already running a local server on that port (like A4Proxy, Multiproxy, or eDexter).

Should this also fail, then try entering dbug..www.yahoo.com/ in your browser's address bar, and see if it is accepted. If it isn't, your browser does not use Proxomitron.



Edited by - Jor on 13 Jun 2002  17:21:09
 

hpguru

  • Sr. Member
  • ****
  • Posts: 257
    • ICQ Messenger -
    • AOL Instant Messenger -
    • Yahoo Instant Messenger -
    • View Profile
    • http://lightning.prohosting.com/~hpguru/
    • Email
Log Window shows nothing at all
« Reply #2 on: June 13, 2002, 05:08:14 PM »
eDexter wouldn't cause the problem unless he changed Proxos listening port to 80.

Gordon are you on dialup or a lan (cable/dsl)? If dialup then open the Internet properties in the Control Panel and click the Connections tab. Then under "Dial-up and Virtual Private Network settings" click the Settings button and under Proxy Server, tick the "Use a Proxy..." box and click the Advanced button. For HTTP type in 127.0.0.1 for the address and 8080 for the Port.

If you are on a lan click the "Lan Settings..." button under "Local Area Network (LAN) settings" and from there the proceedure is pretty much the same as outlined above.

Keep in mind that Opera will not use these settings. In order for Opera to use Proxo you will need to set it up in Operas Preferences.

In Opera, click File, Preferences. In Preferences click Network and then the Proxy servers button. In the Proxy servers dialog, tick the HTTP box and type in the address and port.

If it still isn't working after that then as Jor mentioned it's probably another application is already listening on localhost:8080. To determine if that is the case, reboot your system (to ensure all connections are closed), and when Win98 reloads open a command prompt and type netstat -an. Do you note anything listening on 127.0.0.1:80?

Facing each other,
a thousand miles apart.
Facing each other,
a thousand miles apart.

JakBeNymble

  • Moderator
  • Sr. Member
  • *****
  • Posts: 308
    • ICQ Messenger -
    • AOL Instant Messenger -
    • Yahoo Instant Messenger -
    • View Profile
    • http://
    • Email
Log Window shows nothing at all
« Reply #3 on: June 14, 2002, 02:22:04 AM »
Hi "Gordon Edwards",
                   And WELCOME TO THE FORUM! Glad You are here! If You do have another program listening on port 8080, You can change Proxo to run on any port You want. Click on the Icon, and when Proxo's Main Dialog box pops-up, click "Config">"HTTP", and then set the Port number to what ever number You wish Proxo to run on. But You have to change the number in Your Browser to match it. If Proxo is set, say, to 4002, then in the Http & the Https address line put 127.0.0.1 or 0.0.0.0 or just write localhost. Then in the port number line to the right of the address number You must put 4002. Also make sure that You do not have the "USE SAME PROXY FOR ALL PROTOCOLS" checked. This will cause problems.

And again let me take this opportunity to Welcome You to (What I believe) is the Best FORUM on the "NET"! Let me know if I can be of any help!
I hope You have a Great & Wonderful Day, My Friend!
"jak"


 
 

Gordon Edwards

  • Newbie
  • *
  • Posts: 8
    • ICQ Messenger -
    • AOL Instant Messenger -
    • Yahoo Instant Messenger -
    • View Profile
    • Email
Log Window shows nothing at all
« Reply #4 on: June 14, 2002, 02:29:25 PM »
Jor, hpguru, JakBeNymble -

Thanks for the welcome -- and the advice.

Ummmm...  Er... (deep red blush)

You know that little check-box to the left of the proxy setting in Opera?  Well, I _now_ know what it's for.

(more deep red blush)

I keep a fairly minimal set of extras on this machine: Proxo is the first proxy I have ever worked with -- I like to minimise the amount of fiddling I have to do.

I should say that I got Opera to (eventually) replace IE5.01 'cos I distrust the ActiveX in 5.5 & 6.x, and I will be changing to Linux as soon as that gets simple enough for me to not need a Computer Science degree.  And I downloaded Proxo so I could have the same functionality as Luckman's Anonymous Cookie gives me with IE.

I think I succeeded too well with the cookie bit: this forum and a couple of other sites won't let me in at all if I use the "Monster" cookie -- I can log in, but that's it.  Ah well, back to the drawing-board!  (I'm fairly sure I haven't killed cookies completely.)

Gordon.

 

JakBeNymble

  • Moderator
  • Sr. Member
  • *****
  • Posts: 308
    • ICQ Messenger -
    • AOL Instant Messenger -
    • Yahoo Instant Messenger -
    • View Profile
    • http://
    • Email
Log Window shows nothing at all
« Reply #5 on: June 14, 2002, 06:28:07 PM »
Hi "Gordon Edward",
                  Join the Crowd! We all asked that question sooner or later. I use Proxo as a Site Specific Cookie Manager,http://asp.flaaten.dk/pforum/topic.asp?TOPIC_ID=88
and then for the sites that I allow cookies on, I use Cookie Muncher. http://asp.flaaten.dk/pforum/topic.asp?TOPIC_ID=184
I don't have access to my machine right now or I would just post the changes in the Proxo Cookie Filters that I made.
Take Care, and Please Remember that there are no un-important questions asked here. We all try to help one another as much as we can.
Have a Great & Wonderful Day, My Friend!
'jak'


 
 

Arne

  • Administrator
  • Hero Member
  • *****
  • Posts: 778
    • ICQ Messenger - 1448105
    • AOL Instant Messenger - aflaaten
    • Yahoo Instant Messenger - arneflaa
    • View Profile
    • http://
    • Email
Log Window shows nothing at all
« Reply #6 on: June 14, 2002, 06:37:03 PM »
Hi folks

Just a reminder. Not all cookies are bad ones, and not all javascript is bad either. You can see your cookes from this site here http://asp.flaaten.dk/show_me.asp and javascript is used for both navigation and necessay popups to show things like extra smilies and other stuff. I see nothing wrong with using cookies and javascipt for this purpose.

Best wishes
Arne
Imici username= Arne
Best wishes
Arne
Imici username= Arne

Gordon Edwards

  • Newbie
  • *
  • Posts: 8
    • ICQ Messenger -
    • AOL Instant Messenger -
    • Yahoo Instant Messenger -
    • View Profile
    • Email
Log Window shows nothing at all
« Reply #7 on: June 16, 2002, 01:15:30 PM »
Thanks for the understanding.

I quite agree with Arne: cookies are useful, as is JavaScript -- if you keep them under control!

It is obvious I will have to think through my Proxo setup quite carefully, as it does not offer the same functionality as Luckman's, which I am using now while I navigate this site.  It's about the same as using a truck and a ute -- they don't do _quite_ the same things...

BTW -- I am _very_ impressed with the anti-refresh settings in Proxo: I use AltaVista regularly, but their 300-second auto-refresh used to drive me crazy!  Proxo fixed them up good!

JakBeNymble -- I have just checked out the two forum topics you mentioned.  If anybody is having trouble finding the "Anonymous Cookie", look at http://www.ecwa.asn.au/info/nethygiene.html#We .  You can find a Mac version there too.  However, they only work on IE and some versions of Netscape.  Sadly, not on Opera  8::::(

Cheers,

Gordon.



Edited by - Gordon Edwards on 16 Jun 2002  14:18:06
 

JakBeNymble

  • Moderator
  • Sr. Member
  • *****
  • Posts: 308
    • ICQ Messenger -
    • AOL Instant Messenger -
    • Yahoo Instant Messenger -
    • View Profile
    • http://
    • Email
Log Window shows nothing at all
« Reply #8 on: June 17, 2002, 06:13:30 PM »
Hi "Gordon Edwards",
                   I use to use the Luckman's anon-cookie but stopped when I set Up proxo to manage Cookies. Is there an Advanytage to using both? I would start using it again if there is. I use to use a lot of different programs that did things similar to Proxo, but it took a lot to run them. When I found out what Proxo's features were, I started setting Proxo to replace them all one at a time. But if there is something extra that Luckmans is doing, I will start using it again. It doesn't take anything to run it.

I hope that You have a Wonderful & blessed Day, My Friend!
"Jak"

 
 

Gordon Edwards

  • Newbie
  • *
  • Posts: 8
    • ICQ Messenger -
    • AOL Instant Messenger -
    • Yahoo Instant Messenger -
    • View Profile
    • Email
Log Window shows nothing at all
« Reply #9 on: June 18, 2002, 02:33:05 PM »
G'day Jak, and anybody else who's listening -

Coincidentally, I was researching cookies today, so I've figured out _what_ Luckman's does.

Ummmm...  Yes there is, and no there isn't.  It depends first on what browser you use.  Luckman's _only_ works with IE4,5,6 and Netscape 4,6 (at least I _think_ it works with NS6).  So clever people with Konqueror and Opera (I have 6.03...) don't get it.  Whether it will work with v7 browsers is uncertain.

Now, about Cookies: it seems (certainly on this forum, but basically anything which uses restricted access) that what the site places on your machine is more or less what the site expects your machine to send back.

When we tell Proxo to "fake a cookie", it simply replaces the cookie contents with the text string "Monster": OK for the average Double-Click snoop, but not good for Arne's Forum.

OTH, Luckman's actually interrogates the server's cookie, and extracts the bits the server wants to see, so it can drop them into the client's cookie, along with a string of harmless text which replaces the identifying information.  So it can fool any site completely.

Now that we have this knowledge, I certainly would not mix Proxo with Luckman's: unset ALL cookie management on Proxo if you want to use it with Luckman's.  But if some wonderful person with a lot more programming skills than I have could write a script for Proxo to do what Luckman's does...  I think it will be a big script -- Luckman's is 47K, but that does include calls to help files and all that stuff.

There is one more thing about cookie management with Proxo, which I will start a new thread for.  Look for "Problem with Disabling JS cookies" on this Q&A forum.

I trust that helps.

Gordon.
 

JakBeNymble

  • Moderator
  • Sr. Member
  • *****
  • Posts: 308
    • ICQ Messenger -
    • AOL Instant Messenger -
    • Yahoo Instant Messenger -
    • View Profile
    • http://
    • Email
Log Window shows nothing at all
« Reply #10 on: June 18, 2002, 04:56:56 PM »
HI "Gordon Edwards",
                    Thanks for the info and the link. I have set Proxo to kill all cookies in and out. There are two filters in the default that will do this. However, I have altered them to allow them to have an exceptions list. So No cookies on the HD. So the sites that need cookies to operate I have entered in the Exceptions list. But with "Cookie Muncher" as soon as they come through the window, it chomps it up!

Thanks again for the info. I appreciate You and Your efforts.
Have a Great day, My Friend!
"jak"