Author Topic: HTTP Proxy and Proxomitron  (Read 1099 times)

newglory

  • Newbie
  • *
  • Posts: 1
    • ICQ Messenger -
    • AOL Instant Messenger -
    • Yahoo Instant Messenger -
    • View Profile
    • Email
HTTP Proxy and Proxomitron
« on: July 06, 2002, 05:03:26 PM »
I use an HTTP proxy. I specified the HTTP remote proxy in proxomitron as proxyname:port, but I am not able to block the ADS, if I use the proxy. The proxomitron works fine if I do not connect using the proxy.

The proxo version is Naoko 4.2 and the HTTP proxy in Proxomitron is specified as mtl-1.websecure.freedom.net:443.

I copied ssleay32.dll and libeay32.dll to the proxomitron directory. Also enabled the "Use SSLeay/OpenSSL". Tried to test the proxy thro proxomitron, it still shows HTTP/1.1 even though OpenSSL is loaded. The following is the log of the proxy test:

Loaded: OpenSSL 0.9.2b 22 Mar 1999

Testing mtl-1.websecure.freedom.net:443
Waiting for remote proxy's reply
Proxy test Failed!
>HTTP/1.1 400 Bad Request
Ending proxy test

What could be the issue?

Thanks.

 
 

sidki3003

  • Sr. Member
  • ****
  • Posts: 476
    • ICQ Messenger -
    • AOL Instant Messenger -
    • Yahoo Instant Messenger -
    • View Profile
    • http://
    • Email
HTTP Proxy and Proxomitron
« Reply #1 on: July 06, 2002, 05:26:50 PM »
I can only say just the same as at ComputerCops.
This remote proxy needs a plugin to translate between HTTP and SSL (like JAP) and isn't meant to be used the normal way.

http://www.freedom.net/products/websecure/index.html?product=websecure